Содержание Введение Теоретическая часть Практическая часть Заключение Список использованной литературы Введение icon

Содержание Введение Теоретическая часть Практическая часть Заключение Список использованной литературы Введение



НазваниеСодержание Введение Теоретическая часть Практическая часть Заключение Список использованной литературы Введение
Дата конвертации09.11.2012
Размер292.43 Kb.
ТипРеферат

Содержание

Введение……………………………………………………………………………3

Теоретическая часть……………………………………………………………….4

Практическая часть……………………………………………………………….24

Заключение……………………………………………………………………......30

Список использованной литературы…………………………………………….31


Введение

База данных - это организованная структура, предназначен­ная для хранения информации и ее оперативного поиска по за­данному критерию.

Данные и информация - понятия взаимосвязанные, но не тождественные. Причины содержащегося в определении несоот­ветствия - чисто исторические. В те годы, когда формировалось понятие баз данных, в них действительно хранились только дан­ные. Однако сегодня большинство систем управления базами дан­ных (СУБД) позволяют размещать в своих структурах не только данные, но и методы (т. е. программный код), с помощью кото­рых происходит взаимодействие с потребителем или с другими программно-аппаратными комплексами. Таким образом, мы мо­жем говорить, что в современных базах данных хранятся отнюдь не только данные, но и информация.

Например, база данных крупного банка содержит необходи­мые сведения о клиентах, об их адресах, кредитной истории, со­стоянии расчетных счетов, финансовых операциях и т. д. Кроме данных, база содержит методы и средства, позволяющие каждо­му из сотрудников оперировать только с теми данными, которые входят в его компетенцию. В результате взаимодействия данных, содержащихся в базе, с методами, доступными конкретным сотрудникам, образуется информация, которую они потребляют и на основании которой в пределах собственной компетенции производят ввод и редактирование данных.

С понятием базы данных тесно связано понятие системы управления базой данных — это комплекс программных средств, предназначенных для создания структуры базы, наполнения ее содержимым, редактирования содержимого и визуализации ин­формации. Под визуализацией информации базы понимается отбор отображаемых данных в соответствии с заданным критерием, их упорядочение, оформление и последующая выдача на устройство вывода или передача по каналам связи. В мире существует множество систем управления базами данных. В данной работе рассматривается организация базы данных Excel и Access.


^ Теоретическая часть

Организация базы данных Excel.

Excel может работать как с простыми и небольшими по размерам, так и с более сложным таблицами (списками), которые часто называют базами данных. Excel содержит достаточно широкий набор средств для обеспечения эффективного управления базами данных:

  • организация ввода и просмотра данных;

  • сортировка, фильтрация и консолидация данных в таблицах;

  • подведение итогов и сводная таблица.


Например, база данных представленная в табл.1

^ Таблица 1. База данных Товары

Товарная

группа

Виды товара

Наименование товара

Единицы измерения

Стоимость, руб.

Кондитерские

Конфеты

Белочка

кг

48

Кондитерские

Конфеты

Чародейка

кг

48

Кондитерские

Конфеты

Буревестник

кг

32

Кондитерские

Конфеты

Ласточка

кг

34

Кондитерские

Торт

Весна

Шт.

65

Кондитерские

Торт

Подарочный

Шт.

56

Кондитерские

Торт

Полет

Шт.

70

Мясные

Колбасы

Краковская

кг

36

Мясные

Колбасы

Московская

кг

45

Мясные

Колбасы

Сервелат

кг

60

Мясные

Колбасы

Таллинская

кг

30

Мясные

Консервы

Тушенка говяжья 425 г

Шт.

17,67

Мясные

Консервы

Тушенка говяжья 500 г

Шт.

15,45

Мясные

Консервы

Тушенка свиная 325 г

Шт.

18

Для работы со списками необходимо указать диапазон ячеек, входящий в список. Можно это сделать явным способом, но чаще всего достаточно выделить одну ячейку внутри базы данных, при выполнении операции весь список выделиться автоматически. Следует отметить, что всегда самая верхняя строка найденного диапазона интерпретируется как строка имен полей, нижележащие строки – как строки данных. При выполнении операций с базой данных необходимо указывать имена полей держащих искомую информацию.

Чтобы создать базу данных, можно использовать несколько приемов.

^ Ввод данных на лист Еxcel. Поскольку база данных может рассматриваться как обычная таблица, не содержащая пустых строк и столбцов, то при ее создании можно просто ввести дан­ные на лист книги Ехсе1.

Использовать для ввода содержимого записей окно формы данных.

  1. Задать строку заголовков и выделить ячейку внутри нее.

  2. Выбрать пункт меню Данные/Форма.

  3. На экране отобразится форма данных (рис.1.) — окно,
    содержащее поля вода. Названия полей ввода соответствуют
    именам полей, определенным в строке заголовков.

  4. Ввести содержимое записи, используя для перехода между полями клавишу Tab или щелчок «мыши», затем нажать кнопку Добавить. По этой команде данные будут перенесены в соответствующие поля записи в конце списка.



Рис.1. Окно формы данных

  1. В окне формы справа от полей ввода отображается номер текущей записи и общее число записей базы данных. Ниже расположены кнопки управления списком:

Добавить – создает новую запись;

Удалить – удаляет выбранную запись;

Вернуть – отменяет внесенные в запись изменения;

Далее – вызывает следующую запись;

Критерии – находит запись по заданному критерию пользователя.

  1. После создания списка в него можно добавлять записи, редактировать, удалять.

Сортировка данных позволяет выстаивать данные в алфавитном или цифровом порядке по возрастанию или убыванию. Пустые ячейки всегда помещаются в конце все данных. Excel может сортировать строки списков и баз данных, а также столбцы рабочих листов.

  1. Выделить ячейку внутри базы данных.

  2. Выбрать пункт меню Данные/Сортировка.

  3. В диалоговом окне Сортировка диапазона установить следующие параметры:

Ключи сортировки – столбцы или строки, определяющие новый порядок данных. Для этого в списках Сортировать по, Затем по, В последнюю очередь по выбрать имена полей, используемых для упорядочения списка;



Рис.1. Сортировка данных


^ Порядок сортировки – переключатели по возрастанию и по убыванию, расположенные рядом с каждым ключом;

Идентифицировать поля по – указать, включает ли выделенный диапазон заголовки столбцов;

Параметры – позволяет задать особый порядок сортировки, например по дням неделям.

Если сортировка проводится по одному полю списка, то достаточно выделить заголовок данного поля и использовать кнопки Сортировка по возрастанию или Сортировка по убыванию в стандартной панели инструментов.

Поиск, фильтрация данных.

Поиск данных производится на основе задаваемых критериев — требований налагаемых на информацию. В Ехсеl можно также производить фильтрацию (отбор) данных из списков. Результатом фильтрации является временное скрытие записей, не удовлетворяющих заданным критериям пользователя. В Ехсеl существует три средства для поиска и фильтрации данных: Форма данных, Автофильтр, Расширенный фильтр.

Чтобы найти данные любым из способов поиска или фильтрации, необходимо, прежде всего, задать критерий поиска, т.е. описать то, что надо найти. Критерий может выражаться в различных формах: заданием значения или условия. Для ввода простейшего критерия достаточно ввести в соответствующее поле искомое значение. Например, для поиска мясных товаров в поле Товарная группа указать Мясные.

В критериях на основе сравнения можно использовать различные операции сравнения (=, <, >, >=(меньше или равно), <> (неравно)). Например, чтобы найти товары дороже 40 руб., в поле Стоимость записать условие >40. Перечисленные операции можно использовать не только с числовыми, но и с символьными аргументами. Например, критерий =Т* позволяет найти все значения из поля, начинающиеся на букву «Т».

Кнопка Критерии в окне Форма данных позволяет с легкостью осуществлять поиск и редактирование отдельных записей путем ввода некоторого условия или значения в соответствующее поле ввода. Для просмотра результата поиска используется кнопка Правка и кнопка Далее¸ если заданному критерию удовлетворяет несколько записей.

Автофильтр обеспечивает простой и быстрый способ скрытия лишних записей, оставляя на экране только те, что удовлетворяют критериям.

  1. Выделить ячейку внутри базы данных.

  2. Выбрать пункт меню Данные/Фильтр/Автофильтр.

  3. В правой части заголовка каждого поля (Рис.2.) отобразиться кнопка раскрывающегося списка, с помощью команд которого устанавливается критерий отбора.



Рис.2. Использование Автофильтра

  1. Чтобы отменить предыдущий фильтр, используется команда Все раскрывающегося списка.

  2. Чтобы отключить автофильтр, используется пункт меню Данные/Фильтр/Автофильтр.

  3. Расширенный фильтр лишь немного сложнее Автофильтра, но позволяет накладывать более сложные условия отбора, которые могут даже включать вычисляемые критерии.

Проведение итоговых расчетов.

Excel позволяет получить предварительные результаты, если требуется объединить в отдельные группы. Назначение промежуточных итогов состоит в обобщении данных. Используя команду Итоги, не требуется писать формулы. Excel автоматически создает необходимые математические выражения, вставляет строки промежуточных итогов и структурирует данные. В результате информацию легко обрабатывать. Чтобы правильно подвести промежуточные итоги, требуется сгруппировать данные (отсортировать) по ключевому столбцу, на основании которого будут подводиться итоги

  1. Выделить любую ячейку в списке.

  2. Выбрать пункт меню Данные/Итоги.

  3. В диалоговом окне Промежуточные итоги (рис.3) установить следующие параметры:

  • в списке При каждом изменении в указать поле, на основании которого будут группироваться данные;

  • в списке Операция выбрать операцию, выполняемую над данными;

  • в списке Добавить итоги указать данные, по которым будут подводиться промежуточные итоги.

Рис.3. Вычисление промежуточных итогов по товарным группам

  1. Чтобы отменить расчет итогов, следует воспользоваться командой Данные/Итоги и нажать кнопку Убрать все.


^ Организация базы данных в Access.

Создание таблиц.

Таблицы – это основные объекты любой базы данных, в них хранятся все данные, имеющееся в базе, а также таблицы хранят структуру базы днных.

Мастер таблиц позволяет выбрать поля для данной таблицы из множества определенных ранее таблиц, таких, как деловые контакты, список личного имущества или рецепты. Это программа, ускоряющая создание структуры таблиц. Мастер задает ряд вопросов и, руководствуясь полученными ответами, создает структуру таблицы автоматически.

Использование мастера баз данных позволяет создать базу данных, содержащую все требуемые отчеты, таблицы и формы, за одну операцию. Мастер баз данных создает новую базу данных, но его нельзя использовать для добавления новых таблиц, форм, отчетов в уже существующую базу данных. Несмотря на то, что этот режим служит для упрощения работы, начинающим пользоваться им не рекомендуется, поскольку, не владея всей терминологией, легко запутаться в вопросах и ответах.

Первые таблицы стоит попробовать создать вручную. Для этого есть несколько способов, отличающихся уровнем автоматизации:

  1. Пункт Режим таблицы открывает заготовку, в которой все поля имеют формальные имена: Поле1, Поле2… и т.д. и один стандартный текстовый тип. Имена полей можно изменить, использую команду Переименовать столбец из контекстного меню заголовка поля или двойным щелчком мыши на нем. В пустую таблицу можно сразу вводить данные. При сохранении новой (заполненной) таблицы в Microsoft Access данные анализируются, и каждому полю автоматически присваивается необходимый тип данных и формат.

  2. Определение всех параметров макета таблицы в режиме конструктора.(рис.4.)



Рис.4. Создание таблицы в режиме Конструктора

Наиболее универсальный ручной метод предоставляет пункт Конструктор. В этом режиме можно самостоятельно задать имена полей, выбрать их тип и настроить свойства. Независимо от метода, примененного для создания таблицы, всегда имеется возможность использовать режим конструктора для дальнейшего изменения макета таблицы, например для добавления новых полей, установки значений по умолчанию или для создания масок ввода.

^ Создание таблицы в режиме конструктора.

Рассмотрим более подробно создание таблицы в режиме конструктора. Окно Конструктора таблицы представлено на рис.4. В первом столбце вводят имена полей. Если свойство Подпись для поля не задано, то Имя поля станет одновременно и именем столбца будущей таблицы.

Тип данных для каждого поля выбирают из раскрывающегося списка, открываемого кнопкой выбора типа данных.

Нижняя часть бланка содержит список свойств поля, выделенного в верхней части. Некоторые из свойств уже заданы по умолчанию Свойства полей не являются обязательными. Их можно настраивать по желанию.

Закончив создание структуры таблицы, переходят к вводу данных в режиме таблицы или закрывают бланк. При этом система выдает запрос на сохранение таблицы, после присвоения имени таблица доступна в числе прочих таблиц в основном окне База данных, оттуда ее можно открыть в случае необходимости.



Рис.5. Основные элементы управления модификации таблицы

Заполнение таблицы данными производиться обычным порядком. Курсор устанавливается в нужную ячейку указателем мыши. Переход к следующей ячейки выполнить клавишей Tab. Переход к очередной записи выполняется после заполнения последней ячейки.

При создании таблицы целесообразно задать ключевое поле. Это поможет впоследствии при организации связей между таблицами. Для задания ключевого поля достаточно щелкнуть на его имени правой кнопкой мыши и в открывшемся контекстном меню выбрать пункт Ключевое поле.

Создание межтабличных связей.

  1. Открыть окно Схема данных (рис.6.) используя пункт меню Сервис / Схема данных или кнопку в панели инструментов Базы данных.



Рис.6. Связи между таблицами в окне Схема данных

  1. Если ранее никаких связей между таблицами базы не было, то при открытии окна Схема данных одновременно открывается окно Добавление таблицы, в котором нужно выбрать таблицы для включения в структуры межтабличных связей.

  2. Если связи между таблицами уже были заданы, то для введения в схему данных новой таблицы надо щелкнуть правой кнопкой мыши на схеме данных и в контекстном меню выбрать пункт Добавить таблицу или использовать кнопку в панели инструментов Базы данных.

  3. Связи между полями устанавливают путем перетаскивания имени поля из одной таблицы в другую на соответствующее ему связанное поле.

  4. После перетаскивания открывается диалоговое окно Связи, в котором можно задать свойства образующей связи: включить флажки Обеспечение условия целостности данных, каскадное обновление связей полей и Каскадное удаление связанных записей.

Создание запроса.

Запрос – это объект Microsoft Access, с помощью которого из базы данных извлекаются записи, отвечающие заданны условиям. Запрос можно создать с помощью мастера или самостоятельно.

^ Создание простого запроса на выборку с помощью мастера.

Для создания запроса на выборку с помощью мастера нужно выполнить следующие действия:

  1. В окне базы данных выбрать объект Запросы и нажать кнопку Создать.

  2. В диалоговом окне Новый запрос (рис.7.) выбрать мастера Простой запрос.



Рис.7. Окно для работы с запросами в базах данных

  1. В диалоговом окне Создание простых запросов (рис.8.) в списке Таблиц/запросы, содержащем все таблицы и запросы текущей базы данных, указать имя таблицы или запроса, на котором должен быть основан новый запрос.



Рис.8. Выбор полей в запрос базы данных

  1. Выбрать поля, которые должны включаться в запрос:

Для переноса поля из списка Доступные поля в Выбранные поля следует сделать на нем двойной щелчок или выделить его нажать кнопку с одни символом больше (>). Перенос из списка Доступные поля в Выбранные поля всех данных осуществляется нажатием кнопки с двойным символом больше (>>). Если в списке Выбранные поля окажется лишнее поле, то для его удаления необходимо выполнить на это поле двойной щелчок или, выделив его, нажать кнопку с символом меньше (<). Наконец, если нужно выбрать поля заново, нажмите кнопку с двойным символом меньше (<<).

  1. Если необходимо указать дополнительные таблицы или запрос, а затем выберите из них поля, которые должны быть использованы. Повторять аналогичные действия до тех пор, пока не будут выбраны все необходимые поля. После завершения выбора нажать кнопку Далее.

  2. Выбрать вид отчета: подробный или итоговый (рис.9.). В окне Итоги активировать название той операции, посредством которой будут подсчитаны итоговые значения.



Рис.9. Создание итоговых запросов

  1. В последнем диалоговом окне пользователю предлагается выбор выполнить запрос или просмотреть его структуру в режиме конструктора.

Создание запроса на выборку в режиме конструктора.

Режим конструктора позволяет частично автоматизировать создание объект запрос. Выполнение этой операции осуществляется следующем образок:

  1. В окне Базы данных выбрать Запрос/Создать.

  2. В окне Новый запрос выбрать режим создания запроса – Конструктор. (рис.7.)

  3. В диалоговом окне Добавление таблицы выделить таблицы, на которых будет основан запрос и нажать кнопку Добавить. (рис.10)



Рис.10. Выбор объекта для построения запроса

Запрос может основываться не только на таблицах, но и на других объектах: запросах, запросах и таблицах одновременно. Для этого в окне Добавление таблицы существуют отдельные закладки. Чтобы выделить несколько таблиц одновременно, используется клавиша Shift.

  1. После выбора объектов, на основании которых будет построен запрос, на экране появиться следующее диалоговое окно (рис.11.) – план запроса по образцу (QBE). Выбранные таблицы появятся в верхней половине бланка запроса по образцу.


Таблицы, включенные в запрос

Область маркировки

В банк QBE вставляются поля и записи, которые следует включить в запрос



Рис.11. Окно запроса на выборку в режиме Конструктора


  1. Чтобы включить поле в запрос, можно использовать следующие действия:

  • перенести поля в ячейки бланка запроса с помощью мыши: поместить указатель на название поля в списке полей таблицы и перетащить название поля в первую ячейку строки Поле бланка QBE (рис.12.).



Рис.12. Формирование структуры запроса

  • ввести имя поля непосредственно в ячейку;

  • сделать ячейку в бланке запроса текущей и выбрать нужное поле из раскрывающегося списка;

  • находясь в списке полей таблицы, выполнить двойной щелчок на нужном поле.

  1. По завершении этой операции бланк QBE – запроса будет содержать три поля. При этом флажки Вывода на экран в бланке запроса для всех трех полей будут установлены, т.е. данные всех трех полей должны отображаться в таблице результата.

  2. Чтобы увидеть результат работы запроса, выберите пункт меню Вид/Таблица или нажмите кнопку Конструктор на панели управления. Microsoft Access выведет на экран запись полученного в результате работы запроса динамического набора.

^ Определение условий отбора по запросу осуществляется сл. образом:

  1. Вернитесь в режим конструктора: Вид/Конструктор запросов.

  2. В бланке QBE-запрос перейдите в ячейку Условие отбора поля Наименование и введите нужную продукцию и нажмите клавишу Enter.

  3. Вывести записи динамического набора в виде таблицы можно нажатием кнопки Режиме таблицы на панели инструментов.

Если для одного поля запроса указано несколько условий отбора, Microsoft Access помещает в динамический набор все записи, удовлетворяющие хотя бы одному из указанных условий – первому, или второму, или третьему и т.п. Если два условия отбора указаны для двух разных полей запроса, то при формировании динамического набора в него включаются только те записи, которые удовлетворяют всем указанным условиям – и первому, и второму и т.д.

Список типичных условий отбора, используемых в запросах:

  1. Значение поля равно указанному значению. Чтобы указать такое условие, достаточно ввести нужное значение в ячейку Условие отбора.

  2. Значение поля находится в некотором диапазоне. Введите выражение, которое определяет нужный диапазон значений. (<,>, Between…And…)

  3. Значение поле начинается с указанного значения. Указывается с помощью символа *.

  4. Значение поля принадлежат некоторому списку. Такое условие указывается с помощью функции In().

Проведение расчетов в запросах данных.

Для вычисления итоговых значений запроса необходимо:

  1. Выбрать пункт меню Вид/Групповые операции или нажмите кнопку Групповые операции на панели инструментов. На экране в бланке запроса ОВЕ появится строка Групповые операции.(рис.13.)



Рис.13. Вычисление итоговых значений запроса

  1. Обратите внимание на то, что в каждой ячейке строки Групповые операции автоматически появляется значение Группировка.

  2. В ячейке Групповые операции соответствующего поля выбрать функцию: Sum, Min, Max, Avg(ср.значение) и пр.

  3. Чтобы увидеть результат выполнения запроса, переключитесь в режим таблицы.

Для осуществления расчетов с использованием формул, определяемых пользователем, требуется создать с помощью выражения, которое вводится в пустую ячейку Поле в бланке запроса.

  1. Откройте таблицу, запрос, отчет или форму в режиме Конструктора.

  2. Из контекстного меню строки Поле первого незанятого столба выберите пункт Построить.

  3. В окне Построителя выражений укажите нужную таблицу, запрос, отчет или форму. Постройте нужное выражение, выбирая поочередно щелчком мыши имена соответствующих полей из списка, а также оператор действия с клавиатуры или панели операторов в центральной части окна и нажмите кнопку ок. (рис.14.)



Рис.14. Работа в окне Построить выражений.

  1. Чтобы задать наименование столбца, введите его с клавиатуры в соответствующем столбце по строке Поле, отделив двоеточием от построенного выражения.

Результаты вычислений не должны обязательно отображаться в поле. Их можно использовать в условиях отбора для определения записей, которые выбираются в запросе, или для определения записей, над которыми производится какие-либо действия.

Создание формы с помощью мастера.

Форма - это объект Microsoft Access, который можно ис­пользовать для разных целей: для ввода данных в таблицу, для открытия других форм и отчетов, как специальное окно для вы­бора и предварительного просмотра и печати нужного отчета.

Формы позволяют сфокусировать внимание пользователя на отдельных записях, преодолеть однообразие строк и столбцов таблицы, предоставить доступ к макросам и модулям VBA и, что наиболее важно, просматривать и редактировать данные одно­временно из нескольких таблиц.

Формы создаются аналогично прочим объектам базы дан­ных. Пользователь имеет возможность создать форму самостоя­тельно или воспользоваться мастером. При использовании мастера Microsoft Access выдает приглашение на ввод данных, на основе которых создает­ся форма.

  1. В окне базы данных выберите объект Формы/Создать.

  2. В диалоговом окне Новая форма выберите нужного масте­ра (рис.15). Описание мастера появляется в левой части диа­логового окна.



Рис.15. Выбор мастера форм

  1. Выберите имя таблицы или запроса, содержащих данные, на основе которых будет создана форма, и нажмите кнопку ОК. При использовании мастера форм источник данных для формы следует указывать в диалоговом окне мастера.Если на шаге 3 были выбраны Мастер форм, Диаграмма или Сводная таблица, то при создании формы следуйте инструкциям, выводимым в диалоговых окнах соответствующего мастера. При выборе элементов Автоформа: в столбец, Автоформа: ленточная или Автоформа: табличная форма создается автоматически. Как правило, созданная с помощью мастера форма (рис.16.) неудобна для использования. Чтобы вводить с ее помощью данные в таблицы, нужно помнить коды товаров, персонала и т. д. Возникает необходимость в настройке формы, преобразовании ее элементов, изменении размеров и заголовков полей. Эту работу можно проделать в режиме конструктора, изменив положение и размеры полей, добавив рисунки и элементы управления.



Рис.16. Автоформа в столбец в режиме Формы

Добавление элемента управления к форме или отчету выпол­няется по следующему алгоритму:

1. Откройте форму в режиме конструктора формы.

2. На панели элементов выберите (рис.17.) нужный элемент управле­ния и нарисуйте новый элемент в окне формы путем перетаскивания указателя мыши.



Рис.17. Панель элементов

3.Чтобы вывести на экран список свойств элемента управления, выберите команду Свойства из контекстного меню элемента.


Создание отчетов.

Отчет – это гибкое и эффективное средство для организации данных при выводе на печать в том виде, в котором требуется пользователю.

Пользователь имеет возможность разработать отчет самостоятельно или создать отчет с помощью мастера(рис.18.).



Рис.18. Режим создания отчетов

Мастер по разработке отчетов Microsoft Access выполняет всю рутинную работу и позволяет быстро разработать отчет. После вызова мастера выводятся диалоговые окна с приглашением ввести необходимые данные, и отчет создается на основании ответов пользователя. После этого можно переключиться в режим конструктора и внести изменения в стандартный макет.

Мастер отчетов является настолько мощным средством, что с ним можно получить доступ ко всем возможностям Автоотчетов. Преимущество Автоотчета состоит в том, что вы просто указываете таблицу для построения отчета, а Access сразу создает готовый отчет – при этом во время его создания можно не изменять никаких параметров или настроек.

^ Шаг 1.Выбор полей. Порядок действий, выполняемых на первом шаге Мастера отчетов, аналогичен алгоритму создания запроса на выборку. Нужно обязательно включить все поля, которые имеют отношение к данному отчету, независимо от того, как они будут использоваться: как обобщае­мые данные, как заголовки для упорядочения информации или как значения, по которым будет производиться группировка.

^ Шаг 2. Представление данных. На втором шаге, просматри­вая список полей, нужно выбрать возможную структуру отчета: поля с определением диапазона значений, которые могут ис­пользоваться для группировки информации.

^ Шаг 3. Группировка данных. В следующем окне Мастера от­четов (рис. 19.) необходимо выбрать то поле (или группу по­лей), которое послужит основой для группировки данных по по­лям. Чтобы узнать, как то или иное поле повлияет на структуру записей в отчете, выделите его в списке, расположенном в левой части данного окна.



Рис.19. Выбор полей для распределения записей по группам


^ Шаг 4. Сортировка данных. Следующий шаг Мастера отчетов используется для указания порядка сортировки записей внутри информационной части отчета. Выбор полей для сортировки производится в раскрывающихся списках, где отображаются поля, которые не были использованы для группировки (в груп­пах сортировка происходит автоматически).

Одна из кнопок окна сортировки Мастера отчетов является чрезвычайно важной: речь идет о кнопке Итоги. Ее нажатие приводит к открытию окна диалога Итоги (рис.20.). В нем пе­речислены все числовые или денежные поля, входящие в информационную часть отчета (т. е. не используемые для группи­ровки записей).




Рис.20. Окно диалога Итоги.

Для вычисления итогового значения в группе: суммы или среднего арифметического, минимального и максимального значения или же просто определения количества элементов в груп­пе, нужно установить флажок для той функции, которая будет использоваться в поле.

Группа Показать демонстрирует, будут ли отображаться запи­си внутри каждой группы: опция Данные и итоги отображает всю информацию в отчете; опция Только итоги скрывает данные, за счет чего отчет становится короче.

Для вычисления процентов от итоговой суммы по каждой группе (т. е. расчет удельных весов), в которой вычисляется про­межуточная сумма, устанавливается флажок Вычислить процен­ты. Это позволяет оценить вклад каждой из групп в общий ре­зультат.После того как параметры итоговых вычислений будут за­даны, следует вернуться в окно диалога Мастера отчетов кноп­кой ОК.

^ Шаг 5. Выбор макета. Выбор варианта макета определяет, ка­кая часть информации из базы данных будет повторяться на ка­ждом уровне отчета. Категории группировки отображаются в ле­вой части образца.

^ Шаг 6. Выбор стиля. Последнее окно диалога Мастер отчетов позволяет выбрать стиль оформления. Стили совпадают с теми, которые активизируются по команде Автоформат в режиме конструктора отчетов. Они автоматически применяют в макет отчета определенные шрифты, обрамление и интервал.

Практическая часть

Задача.

1. Построить таблицы по приведенным ниже данным (рис. 21-23).

2. Выполнить расчет исходящих остатков вкладов.

3. Организовать межтабличные связи для автоматического формирования ведомости остатков вкладов с начисленными процентами.

4. Результаты вычислений представить в графическом виде.

лицевого счета

Вид вклада

^ Сумма вклада

Остаток входящий, тыс.руб.

Приход, тыс.руб.

Расход, тыс.руб.

Остаток исходящий, тыс.руб.

R6798

До востребования

54




4




F5774

Праздничный

45










S3354

Срочный

76

8

9




G6723

До востребования

15

12

2




Z3421

Срочный

6

3







Рис.21. Операционный дневник


лицевого счета

Вид вклада

^ Остаток вклада с начисленным процентом, %

R6798

До востребования




F5774

Праздничный




S3354

Срочный




G6723

До востребования




Z3421

Срочный




Рис.22. Остаток вклада с начисленным процентом


^ Вид вклада

Процентная ставка, %

До востребования

2

Праздничный

5

Срочный

3

Рис.23. Процентная ставка


Решение.

1. Запустить табличный процессор MS Excel.

2. Лист 1 переименовать в лист с названием Дневник.

3. На рабочем листе «Дневник» MS Excel создать таблицу операционного дневника.

5. Заполнить таблицу операционного дневника исходными данными.



Рис.24 Расположение таблицы «Операционный дневник» на рабочем листе Дневник MS Excel


6. Заполнить графу «Остаток исходящий» таблицы «Операционный дневник», находящийся на листе Дневник следующим образом:

Занести в ячейку F4 формулу:

=C4+D4-E4



Размножить введенную в ячейку F4 формулу для остальных ячеек (с F5 по F8) данной графы.



Рис.25. Расположение таблицы «Операционный дневник» на рабочем листе Дневник

MS Excel

7. Лист 2 переименовать в лист «Остаток вклада с %».

8. На рабочем листе «Остаток вклада с %» MS Excel создать таблицу «Остаток вклада с начисленным процентом».

9. Заполнить данную таблицу исходными данными.



Рис.26. Расположение таблицы «Остаток вклада с начисленным процентом» на рабочем

листе «Остаток вклада с %» MS Excel


10. Лист 3 переименовать в лист «% ставка».

11. На рабочем листе «% ставка» MS Excel создать таблицу «Процентная ставка».

12. Заполнить таблицу «Процентная ставка» исходными данными.



Рис.27. Расположение таблицы «Процентная ставка»

на рабочем листе «% ставка» MS Excel


13. Заполнить графу «Остаток вклада с начисленным процентом» таблицы «Остаток вклада с начисленным процентом», находящийся на листе «Остаток вклада с %» следующим образом:

Занести в ячейку C3 формулу:

= ПРОСМОТР(B3;'% ставка'!$A$3:$A$5;'% ставка'!$B$3:$B$5)*Дневник!F4




Размножить введенную в ячейку C3 формулу для остальных ячеек (с C4 по C7) данной графы.



Рис.28. Расположение таблицы «Остаток вклада с начисленным процентом»

на рабочем листе «Остаток вклада с %» MS Excel


14. Лист 4 переименовать в лист «График»

15. В строке меню команды выберем Вставка/Диаграмма/Гистограмма и далее. Затем выбираем диапазон, для этого переходим на лист «Остаток вклада с %» и выбираем ячейки с А3 по А7, далее удерживая Ctrl, выбираем ячейки с С3 по С7(Рис.29.). Затем нажмем далее. Заполняем название диаграммы, подписываем ось Х и Y(Рис.30.). Затем далее. Поместить диаграмму на листе «График» (Рис.31.).



Рис.29.




Рис.30.




Рис.31. Расположение графика «Распределение остатков вклада с начисленным процентом по лицевым счетам»

на рабочем листе «График» MS Excel


Заключение

Основой для учета, контроля и планирования служат всевозможные картотеки, регистрационные журналы, списки и т.д. Они постепенно накапливаются и обновляются. При большом объеме информации поиск и обобщение необходимых сведений, осуществляемых вручную, представляют собой довольно трудоемкий процесс.

С появлением ЭВМ и использованием их для обработки информации появилась возможность автоматизировать решение многих информационно - справочных и расчетных задач. С развитием ЭВМ появилась возможность создание баз данных. В данной работе было рассмотрено создание их в Microsoft Office Excel и Access. Microsoft Office Excel объединяет в себе возможности: тестовых процессоров по созданию и форматированию таблиц; математической обработки табличных данных; визуализации результатов в форме таблиц, диаграмм, графиков. Электронные таблицы можно использовать для решения задач учета, составления бланков, планирование производства, расчета налогов и зарплаты, учета кадров и др. Благодаря мощным математическим фикциям, имеющимся в электронных таблицах, с их помощью можно решать множество задач в области естественных и технических наук.

В Access предусмотрены все необходимые вам средства для определения и обработки данных, а также для управления ими при работе с большими объемами информации. Используя запросы, мы можем выбирать и обрабатывать хранящуюся в таблицах информацию. Можно создавать формы для ввода, просмотра и обновления данных, а также использовать Access для создания как простых, так и сложных отчетов. Формы и отчеты «наследуют» свойства базовой таблицы или запроса, так что в большинстве случаев вы указываете форматы, условия на значения и некоторые другие характеристики данных только один раз. К числу наиболее мощных средств Access относятся средства разработки объектов - Мастера, которые мы можем использовать для создания таблиц, запросов различных типов форм и отчетов, просто выбрав с помощью мыши нужные опции.

Microsoft Access имеет множество областей применения: на малом предприятии; в работе по контракту, когда мы разрабатываем прикладные программы по заказу или выступаете в роли консультанта; в больших корпорациях, когда вы выступаете в роли координатора производственных информационных систем и даже в сфере домашнего применения.


Список использованной литературы.

  1. Акулов О.А., Медведев Н.В. Информатика: базовый курс. – М.: Омега-Л,2005

  2. Информатика. Базовый курс. 2-е издание/Под ред. С.В.Симоновича. - СПб.: Питер, 2007.-640с.

  3. Информатика. Учебник. – 3-е перераб. изд./ Под ред. Н.В.Макаровой. – М.: Финансы и статистика, 2002.-768с.

  4. Информатика: учебник/Б.В.Соболь [и др.]. – Ростов н/Д: Феникс, 2006.-448с. (Высшее образование)

  5. Каймин В.Л. Информатика: учеб. – М.: ТК Велби, Издательство Проспект, 2007.-272с.

  6. Могилев А.В. Информатика: Учеб. пособие для студ. пед. Вузов/ А.В.Могилев, Н.И.Пак, Е.К.Хеннер; Под ред. Е.К. Хеннера.- 3-е изд., перераб. и доп. – М.: Издательский центр «Академия», 2004.-848с.

  7. Сергеева И.И.., Музалевская А.А., Тарасова И.В. Информатика: учебник. – М.: ИД «Форум»: ИНФРА-М, 2008.-336с.

  8. Степанов АН. Информатика: Учебник для вузов. 5-е изд. - СПб.: Питер,2007.-765с.










Похожие:

Содержание Введение Теоретическая часть Практическая часть Заключение Список использованной литературы Введение iconСодержание Введение Назовите основные виды искажений бухгалтерской отчетности Что представляет собой заведомо ложное аудиторское заключение Заключение Практическая часть Список использованной литературы Введение
Целью аудита является выражение мнения о достоверности финансовой (бухгалтерской) отчетности аудируемых лиц и соответствии порядка...
Содержание Введение Теоретическая часть Практическая часть Заключение Список использованной литературы Введение iconСодержание Введение 3 Теоретическая часть 4 Заключение 13 Тесты 15 Список литературы 18 Введение
Так как эти группы пользователей имели различные интересы и различные потребности в информации, принципы, лежащие в основе составления...
Содержание Введение Теоретическая часть Практическая часть Заключение Список использованной литературы Введение iconЭкстрадиция: правовые основания, условия и порядок выдачи содержани е введение 2 Основная часть 3 Заключение 14 Список использованной литературы 15 Введение
В настоящее время экстрадиция – важный институт в укреплении и развитии международного сотрудничества между государствами
Содержание Введение Теоретическая часть Практическая часть Заключение Список использованной литературы Введение iconСодержание Введение 1 Теоретическая часть 1 Метод Гаусса 1 Метод Зейделя 4 Сравнение прямых и итерационных методов 6 Практическая часть 7 Введение
Эвм. Значительная часть численных методов решения различных (в особенности – нелинейных) задач включает в себя решение систем линейных...
Содержание Введение Теоретическая часть Практическая часть Заключение Список использованной литературы Введение iconСодержание. Теоретическая часть Задание Текст программы. Блок-схема программы Выполнение программы в математическом пакете Список использованной литературы Теоретическая часть
Численные методы могут использоваться для вычисления кратных интегралов. Ограничимся рассмотрением двойных интегралов вида
Содержание Введение Теоретическая часть Практическая часть Заключение Список использованной литературы Введение iconСодержание I. Введение Жизненный цикл товара а Маркетинговые стратегии Методы маркетинговых исследований Тест Заключение Список использованной литературы Введение
Возросшая конкуренция вынуждает предприятия изготовителей идти на все большие уступки потребителям и посредникам в сбыте своей продукции...
Содержание Введение Теоретическая часть Практическая часть Заключение Список использованной литературы Введение iconСодержание введение Прибыль и ее роль в рыночной экономике Методы планирования прибыли Распределение и использование прибыли Заключение Расчетная часть Смета II. 1 Список используемой литературы Краснодар, 2007 введение
Прибыль в условиях рынка используется не на потребление, а на инвестиции и инновации, которые обеспечивают экономический рост предприятия...
Содержание Введение Теоретическая часть Практическая часть Заключение Список использованной литературы Введение iconПлан I. Введение 3 II. Основная часть 4 Понятие и основание залога Виды залога и сфера его применения Предмет залога и стороны залогового правоотношения Оформление залога Прекращение залога III. Заключение 19 Список использованной литературы 20 I введение
Сейчас в условиях низкого уровня договорной дисциплины, ненадежности и часто просто недобросовестности контрагентов все большее развитие...
Содержание Введение Теоретическая часть Практическая часть Заключение Список использованной литературы Введение iconСодержание место России на мировом валютном рынке Введение понятие о валютном рынке страны валютный рынок России Заключение Список литературы Практическая часть Тест Задача введение
У каждой страны есть свои деньги. Они служат средством обмена или средством платежа, единицей счета, средством сохранения стоимости,...
Содержание Введение Теоретическая часть Практическая часть Заключение Список использованной литературы Введение iconРеферат должен быть набран на компьютере с соблюдением следующих требований: поля 2,5 см; шрифт Times New Roman (по ширине); интервал 1,5; размер шрифта: основной текст 14; заголовки 14 (жирный). Страницы проставляются внизу (по центру)
Структура реферата включает: введение, основную часть, заключение, список использованной литературы
Разместите кнопку на своём сайте:
Документы


База данных защищена авторским правом ©rushkolnik.ru 2000-2015
При копировании материала обязательно указание активной ссылки открытой для индексации.
обратиться к администрации
Документы